SAP Knowledge Base Article - Public

2700139 - E-mail and Phone Number for Business Partners are not Being Sent Over from ERP through Odata

Symptom

You send Business Partners from ERP through Odata to Cloud for Customer (C4C) and see that the e-mail and phone number are not being sent over.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisites: you have a working integration scenario by using interface BusinessPartnerReplicationIn.

  1. Send a Business Partner from ERP to C4C with an Odata service.
  2. Open the Business Partner.
  3. E-mail and Phone number fields are empty.

Cause

You send the data for e-mail and phone number within the wrong node in the payload.

Resolution

The data should be sent under the EmailUsage and TelephoneUsage nodes in the payload.

E.g. for EmailUsage:

EmailUsage.png

Keywords

E-mail and Phone number Odata, Odata Business Partner , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins 1805 ; SAP Cloud for Customer add-ins 1808

Attachments

EmailUsage.png