Symptom
An Action is not visible in the UI for a specific Business Role.
Environment
SAP Cloud for Customer
Reproducing the Issue
Log into the system with the User DEF. User DEF is assigned to the Business Role XYZ. (DEF represents the User ID and XYZ represents the Business Role ID)
-
Go to the Sales work center.
- Go to the Leads work center. (not specific to Leads BO).
- Open the Lead ABC (ABC represents the Lead ID).
- Select the Actions button.
- The action Convert to Account and Contact is not visible but it is for other business users. (Not specific to this action)
Cause
A possible reason for this is that the action has been hidden via Page Layout.
Resolution
Prerequisite: Check what Page Layout the Business Role XYZ is assigned.
- Log into the system with an Administrator User.
- Select the Adapt button---->Assign Page Layout.
- On the left header, choose the Leads business object.
- The Business Roles and corresponding Page Layouts are now displayed on the right.
Now, you can either assign another Page Layout for that Business Role or edit the existing Page Layout and make the action visible.
- Log into the system with an Administrator User.
-
Go to the Sales work center.
- Go to the Leads work center.
- Open any Lead ID.
- Select the Adapt button---->Edit Page Layout.
- You can either select a new Page Layout where this action is visible, or edit the existing Page Layout by adding the action.
Keywords
KBA , leads , business role , edit page layout. , action , LOD-CRM-LM , Lead Management , Problem