SAP Knowledge Base Article - Public

2701023 - The Query doesn't ReturnThe Correct Search Results In The Contacts OWL

Symptom

In the Contacts OWL, you have executed a search for Contacts with Email Is Initial (should return only Contacts where there is no email maintained) However, Contacts with an Email Address are visible in the search results.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Contacts view.
  3. Open the Advanced Filter.
  4. In the Email field, select the More options icon. (Issue not specific to the E-mail field)
  5. Select the Is initial value from the Options field.
  6. Select the Ok button.
  7. Now select the Go button.
  8. Contacts with an Email address are visible in the results.

Cause


The Contact OWL searches in all Contact Relationships not only in the default Contact Relationship as shown in the OWL result.

If a Contact has a relationship maintained with an Account/s in the Relationships tab, and an Email is maintained, then this will appear in the search results.

Resolution

If you do not want this behaviour, as of now our reccomendation is to remove these Relationships from the respective Contacts. In a future release, our development colleagues plan to implement a hidden search parameter available that allows restriction to default Contact person relationships only.

Keywords

KBA , customers , contacts , email , is initial , visible , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer add-ins 1808 ; SAP Cloud for Customer add-ins 1811 ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1808 ; SAP Cloud for Customer core applications 1811 ; SAP Cloud for Customer core applications all versions