SAP Knowledge Base Article - Public

2701173 - Receiving Error: 'AlienNumber length is not 9' When Completing E-Verify Activity - Onboarding 1.0 [E-Verify] [User Handling]

Symptom

Receiving Error: 'AlienNumber length is not 9', see below image for visual reference.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

SAP SuccessFactors Onboarding 1.0 - All Versions

Reproducing the Issue

  1. Navigate to SAP SuccessFactors HCM > Onboarding
  2. Pick up any candidate from E-Verify tab
  3. When trying to Submit Initial Verification, the error message 'AlienNumber length is not 9.' appears:

kba#1.png

Cause

The system validated that Alien Number entered in the candidate's data is less/more than 9. Common cause of this warning message is where Hiring Manager/Orientation Step Assignee, entered incorrect information in the system.

Resolution

For Live Customer(s)

Please reach out to SAP SuccessFactors Cloud Product Support in SAP for Me via Support case to request change of record. In addition, follow the template when creating an case and provide the needed information below.

  • Subject: KBA 2701173 - Receiving Error: 'AlienNumber length is not 9'
  • Component: LOD-SF-OBD-EVF

Problem Description:

  1. BizX Company ID 
    • [Insert affected instance]
  1. Affected Hire/Candidate
    • [Insert affected hire/candidate's name]
    • [Insert screenshot of the issue]
    • [Insert Alien Number and Card Number in a text file]
  • Note
    • Enter the information in a text file (.txt) and attached it in the case with confidential marking.
  1. Permission to Change Alien Number
    • [Insert approval]
  1. Username for Support Access (Read the agreement below)
    • [Insert Username]
  • May we have your approval for accessing your system environment to continue request? (Reply with your confirmation and username to access, refer to KBA listed below)
  • With your approval, accessing your system environment you agree for the actions we will take below.
    1. Review the data of affected users and compare it to those users who are working as expected.
    2. Capture screenshots/record screen clips of the issue.
    3. Analyze your system configuration
  • To know how to grant support access to SAP Cloud Product Support, please read the full article on 'How to Grant Support Access to SuccessFactors Support Staff' by clicking the reference KBA 2088892.

See Also

Keywords

E-Verify, DHS, Verification, Work Authorized, Alien Number, Authorized to Work, card number, Receiving Error: 'AlienNumber length is not 9'

, KBA , LOD-SF-OBD-EVF , e-Verify , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions