SAP Knowledge Base Article - Public

2705401 - The Proceeding 0000 Are Missing For The Product External ID in Opportunities Replicated to C4C

Symptom

The proceeding 0000 are missing for the Product External ID in Opportunities replicated to C4C

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Open the Opportunity ABC (ABC represents the Opportunity ID).
  4. Go to the Products tab.
  5. The External Product ID is shown as 86 (for example) instead of 000086.

Cause

This is currently the expected system behaviour.

Resolution

Our developers have confirmed that they plan to change this behaviour so that the proceeding zeros are included in the Product external ID but as of now there is not set date for this fix.

Keywords

KBA , 0000 , product external id , opportunities , replicated , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins 1808 ; SAP Cloud for Customer add-ins 1811 ; SAP Cloud for Customer add-ins 1902 ; SAP Cloud for Customer core applications 1808 ; SAP Cloud for Customer core applications 1811 ; SAP Cloud for Customer core applications 1902