SAP Knowledge Base Article - Public

2705443 - Notifications of a Different User Shown For a User

Symptom

In the Notification Center on the left side pane, you are unable to see the Notifications which belong to you, but instead see the Notifications belonging to a different user.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Login to the system in either HTML5/Fiori
  2. Click on the Notification Center on the Left Side Pane
  3. The Notifications shown are that of a different user

Cause

The Notifications displayed are those of an impersonate user - the user who is used as proxy while using the 'Logon as Another User' functionality. This could occur because a business user or key user has been used to impersonate your business user previously.

Even if you remove the impersonate user entry from the 'Logon as Another User' screen, this would still be registered in the backend, causing this problem.

Resolution

It is recommended to never use a business user or key user to impersonate another user. Always create a KEYTEST user for this purpose. To remove the already registered entries from the backend, kindly reach out to SAP Support.

See Also

Logon as Another User - C4C Help Center

Keywords

notification, keytest, logon as another user, impersonate, missing , KBA , notification , keytest , missing , SRD-CC-BTM , Business Task Management , AP-RC-UIF-RT , UI Framework Runtime , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer add-ins 1808 ; SAP Cloud for Customer add-ins 1811