SAP Knowledge Base Article - Public

2705787 - Error 'Enter a Customer' While Importing Registered Product Via Data Workbench

Symptom

You have the requirement to import Registered Products via Data Workbench, however the import is failing with below error:

'Enter a customer'

When checking the template, you do not find the Customer ID field to enter the information.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Data Workbench work center;
  2. Open Import Tab;
  3. Choose Individual Object;
  4. Select the object Registered Product;
  5. Click Next;
  6. Upload the template with the new registered product information;
  7. Finalize the import process;
  8. Go to Monitor view;
  9. Open the results file and see the error 'Enter a customer';
  10. Check the CSV file and verify hat there is no Customer field in the template.

Cause

There is a separate entity “Party” in the Registered Product object. This can be used to create/update/export all parties like Customer in this case.

Resolution

In order to create new Registered Products, you have to use the Complete Business Object of Registered Products and fill the Customer ID (Role Code = 60) in this Party separate template.

This is the expected system behavior.

Keywords

Registered Product, Field, Customer, Data Workbench, Complete Business Object , KBA , LOD-LE-IBA-IPO , Installation Point , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions