Symptom
When importing data using the Import Data Tool, it fails and you can see this error in the Error Log File:
The record could not be added because the system failed to import it. Please import again the records that failed.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Go to System Admin > System mgmt Tools > Import Data >
- Upload a template to import data into Learning >
- Import status is FAILED >
- Download the Error Log file and check the Comment columns (for each tab of the file) and some will have this error.
Cause
This error could have multiple cause and usually means there is no specific error message coded in the application.
Resolution
- The import tool will import the data in the application proceeding in order of the tabs available in the input file. Once a row triggers an error, all subsequent rows and tabs could show the same error.
- Therefore, the best way to proceed is to start with the first tab where you see this error (in case the error is in multiple tabs) and try to fix the error there first.
So for example, you are importing Exam data in Learning for your PQE migration:
This import file will have 4 tabs: Exam, Exam Questions, Exam Question Feedback and Exam Objectives. You need to check each tab for the Comment column to verify where the error is and focus on trying to fix the data in the first tab where the error is.
As per our example, if the error is in the Exam Question Feedback and Exam Objectives tabs but NOT in the Exam, Exam Questions,
- first review and fix the data in the Exam Question Feedback.
- Check the data in the UI to see if you can access the question record, do you get any error there?
- Check the status of the record, is it active (we should not import inactive questions in the system)
- try to import again and see if you still get the error in this tab
- if not proceed with the same on the other tabs where you now see the error
In the event where you would require assistance, please, log a case under the "LOD-SF-LMS-IMP" component and, please, provide the following information:
- Support access for the admin who performed the import >
- Or please grant us permission to replicate on our end >
- Please, attach the error log file >
- Please, attach the import file >
- If you got any errors in the UI while accessing the record please share a screenshot.
Keywords
LMS, Learning, Management, System, Import, Tool, Import Tool, Import Data, Data, Template, The record could not be added because the system failed to import it, Error, Fail, cannot import, fail import, import failed, pqe, migration, question, exam, assessments , KBA , LOD-SF-LMS-LEG , Legacy Learning Issues , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-IMP , Import Data Tool , Problem