SAP Knowledge Base Article - Public

2707770 - It is Allowed to Add the Same Custom Party Role More Than Once Within the Registered Product's Involved Parties

Symptom

In the Registered Product , can add more than 1 party with the same custom role.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Click on the Activity List and search for the fine tune activity name Involved Parties for Registered Product , Installed Base and Installation Point.
  4. Click on the Add Row button and add custom party role Z_ABC (where Z_ABC is the custom party role).
  5. You can see we do not have Unique column available to mark/check the role as unique.
  6. Go to the Installed Base work center.
  7. Go to the Registered Product view and open registered product LMN (where LMN is the registered product id) .
  8. Go to the Involved Parties facet and click on the Add button.
  9. Add the custom party role Z_ABC and value for it .
  10. Repeat the same step again by adding Z_ABC second time .
  11. Now click on the save button.

You do not get error as Can not add more than 1 party for the same role.

Cause

We are allow to add the same custom party role more than once in registered product.But if you add standard party role more than once it will trigger error .

Resolution

This is an expected system behavior for custom party role for registered product.

Keywords

Involved Parties for Registered Product, Custom Party Role , KBA , unique column missing , LOD-LE-IBA-IPO , Installation Point , LOD-LE-IBA-IBA , Installed Base , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions