SAP Knowledge Base Article - Public

2708022 - You cannot Add an E-mail to a Lead or Opportunity via the Outlook add-in without Selecting an Account first

Symptom

You would like to add an email to a Lead or Opportunity using the Outlook add-in. However, the options Lead and Opportunity are greyed-out.

AddEmailViaOutlook.jpg

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log in to the Outlook add-in.
  2. Click Add E-Mail.
    The window shown in the screenshot will open.
  3. Click Add Reference.
    Result: The option Opportunity and Lead are greyed-out.
  4. Select Account.
  5. Choose the account that your opportunity/lead has.
    Result: The option Opportunity and Lead will now be available.

Cause

It is not possible to add an e-mail to a lead/opportunty which does not have an account using the Outlook add-in.

Resolution

You can manually add the e-mail to the Leads/Opportunities Attachments facet in the UI.

Keywords

outlook add-in, add, email, e-mail, lead, opportunity, account, add reference , KBA , LOD-CRM , Cloud for Customer , How To

Product

SAP Cloud for Customer add-ins 1811