Symptom
Wrong Pre-set of Partner Role in Visit Facette Email Recipient : Error "Save failed. Entry 123456 for party role field not consistent as per code list restriction"
Environment
SAP HYBRIS CLOUD FOR CUSTOMER
Reproducing the Issue
- Go to the Visit workcenter.
- Go to the Visits view.
- Create an new Visit open an existing Visit.
- Go to the E-mail recipients tab.
- Click Add.
In the pop-up window designed for Involved Party addition, the drop down list is incorrect.
6. Proceed to Add an Involved Party.
Result: An error message is displayed: "Save failed. Entry <123456> for party role field not consistent as per code list restriction".
Cause
Currently, it is the standard behaviour : When one of the value is set as default and Code List Restriction takes place further down.
This defaulting behaviour can be overwritten by using the default value option in Code List Restriction section of the Administrator workcenter.
Resolution
If you want one valid value to be defaulted all the time for ROLE, you could do that by creating new CLR on ROLE (without any control field) and set a default value so that its applicable to all the cases irrespective of control field values.
Or you could also set defaulting behaviour based on control fields as well.
Keywords
Partner Role in Visit, Save failed. Entry for party role field not consistent as per code list restriction, , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem