Symptom
You are trying to change or maintain an account in the field Top-Level Account for the account ABC (ABC represents the Account ID), but this is field is not editable (grayed out).
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Open the account ABC.
- Click in the Edit button.
- You will see that you are not able to edit the information of the field Top-Level Account.
Cause
The field Top-Level Account is not editable because this field is type="link" field and not a type="Input field".
During a new Account creation, the field Parent Account will be the Top-Level Account which will be displayed. The Account Hierarchy will be displayed only when you have a Parent Account added/mapped during the account creation.
Resolution
To change the field Top-Level Account, you can update/edit the Parent Account field to see the Top-Level Account to reflect the same.
Keywords
Top-Level Account, Account, Account Hierarchy , KBA , LOD-CRM-ACC , Account , How To