SAP Knowledge Base Article - Public

2709066 - Involved Parties Are Not Re-Determined in Follow Up Documents

Symptom

You are creating a follow up document, for example a Sales Quote from an Opportunity, and you are expecting that the Involved Parties of the follow up sales quote are determined based in the Involved Parties Determination of the Fine-Tune Activity Sales Quotes.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Open the opportunity ABC (ABC represents the Opportunity ID).
  4. Go to the Sales Documents facet.
  5. In the Sales Quotes section, click in the New button.
  6. Click on Save and Open.
  7. Go to the Involved Parties facet of the sales quote created.
  8. You will see that the involved parties were copied from the opportunity ABC and not re-determined.

Cause

In case a document is created as follow-up document e.g. a Sales Quote is created as follow-up from an Opportunity, then the party roles existing in both party schema will be copied over.

For example, you have the party role XYZ (XYZ represents the Party Role Name) maintained as the Current User in the Involved Parties Determination for Opportunities and Sales Quotes. Therefore when you create a new opportunity the current user will be determined as an involved party for the role XYZ. If you create a follow up sales quote from this opportunity, the party role XYZ will be copied from the opportunity and not re-determined as the "new" current user.

The determination will only occur if there isn't a party role XYZ maintained in the involved parties of the opportunity, then when you create the follow up sales quote the system will determine the current user as the party role XYZ in the involved parties of the sales quote.

Resolution

This is the expected system behavior.

If you need a custom logic to re-determine the involved parties of the follow-up document,  you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.

An alternative option may be to check the SAP Customer Influence Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer

See Also

SAP Blog Post - Overview on Party Determination and Involved Parties in SAP Hybris Cloud for Customer

Keywords

Follow up, Documents, Involved Parties, Determination, Party Role, Opportunities, Sales Quotes , KBA , LOD-CRM-OPP , Opportunity Management , LOD-LE-CQP , Customer Quote Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions