SAP Knowledge Base Article - Public

2709232 - Document Routing Notification Not Triggered - Performance Management

Symptom

Document Routing Notification is not sent after the Form was routed.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Create a route map that would have more than one step in Modify Stage that would be an Employee step:

Route map steps.png

  1. Launch form which relates to created route map.
  2. Via Form Route Tool, route the form from Employee step to the other step that would also be an Employee's step.
  3. The form is routed successfully; however, the employee did not receive Document Routing Notification.

Cause

This is expected system behavior.

Resolution

  1. Both steps are Employee steps. At 1st step, the form is already in the Employees document inbox.
  2. If the form is routed to the 3rd step, form remains in the Employees in box, as the 3rd step is also Employee's step.
  3. Therefore, Document Routing Notification is not triggered for an Employee as the form was already in Employee's inbox.

Route.png

Keywords

SF, success factors, PMGM, PM, Form Routing Notification, Email Notification, Not Triggering, Document Notification, Form Notification , KBA , LOD-SF-PM-EML , Emails and Notifications , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Performance & Goals all versions