Symptom
Workflow Rules for sending notifications for Sales Orders not working.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to Application and User Management work center.
- Go to Workflow Rules view
- Select the Rule XYZ. (XYZ represents the Rule Description)
Eventhough the Rule is Active, user are not receiving email notifications related to sales order as per the Rule.
Cause
In a non-productive system you can specify whether e-mails and faxes should be sent to real addresses of business partners or to an address used for testing purposes. In this case user choose "Send all e-mails/faxes to this address", But the email address is not maintained.
Resolution
-
Go to Business Configuration work center.
- Go to Implementation Projects view.
- Choose Show: All Open Projects.
- Choose relevant project and Choose Open Activity List.
- Select Fine Tune.
- Search the activity E-Mail and Fax Settings.
- Click on Open button.
- Select E-Mail and Fax Settings.
- Under E-Mail and Fax Delivery in a Non-Productive System.
- Either select Send all e-mails to business partners or select Send all e-mails to this address and maintain the email address.
- Click on Save.
Keywords
email missing, notification failed, no output, email, e-mail, workflow rule, notifications, sales order, email address , KBA , rule not triggering , active rule not working , AP-SLO-SO , Sales Order , Problem