SAP Knowledge Base Article - Public

2709386 - Workflow Rule not Working for Sales Orders

Symptom

Workflow Rules for sending notifications for Sales Orders not working.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Application and User Management work center.
  2. Go to Workflow Rules view
  3. Select the Rule XYZ. (XYZ represents the Rule Description)

Eventhough the Rule is Active, user are not receiving email notifications related to sales order as per the Rule.

Cause

In a non-productive system you can specify whether e-mails and faxes should be sent to real addresses of business partners or to an address used for testing purposes. In this case user choose "Send all e-mails/faxes to this address", But the email address is not maintained.

Resolution

  1. Go to Business Configuration work center.
  2. Go to Implementation Projects view.
  3. Choose Show: All Open Projects.
  4. Choose relevant project and Choose Open Activity List.
  5. Select Fine Tune.
  6. Search the activity E-Mail and Fax Settings.
  7. Click on Open button.
  8. Select E-Mail and Fax Settings.
  9. Under E-Mail and Fax Delivery in a Non-Productive System.
  10. Either select Send all e-mails to business partners or select Send all e-mails to this address and maintain the email address.
  11. Click on Save.

Keywords

email missing, notification failed, no output, email, e-mail, workflow rule, notifications, sales order, email address , KBA , rule not triggering , active rule not working , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions