SAP Knowledge Base Article - Public

2709760 - Customer Satisfaction Survey Does Not Work For Lead

Symptom

Customer Satisfaction Survey is defined, and the Workflow is created for triggering an email to the customer when lead is created. Survey is working fine for the Tickets, but not for the Leads. Workflow designed for the Lead deliver the email to recipient, however the link in the email received does not open for responding the survey.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1.  Create a workflow rule for Lead for sending Customer Satisfaction Survey SurveyXX (where "XX" represents Survey ID) to the recipient Customer.
  2.  Survey is sent out from Lead ID XXXX (where XXXX represents Lead ID).
  3.  Recipient of the email Click the survey link on received email.
  4.  Recipient clicks on the Survey Link received in the email when a lead is created. This link does not generate survey.

Cause

The customer used in creation of Lead, for the Customer satisfaction survey is of an Account as Organization and not the individual Customer.

If Customer/Account used in creation of Lead is an Organization, instead of an individual customer, then an email received by recipient will not generate the survey from the Survey link.

This is expected behavior.

Customer satisfaction for lead Workflow.jpg

Resolution

In Lead Object, Workflow must be defined for sending an email for the Customer Satisfaction Survey for the customer/ Account ID on the "Define Actions", where in customer/ Account ID is an Individual Customer.

Keywords

Lead, workflow, Survey in Lead, Not Work, Individual Customer. , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions

Attachments

Customer satisfaction for lead Workflow.jpg