Symptom
You created a new time report and now you want to display the Total Duration in the standard report All Time Entries (technical ID CODTIME_ENTRY_Q0001) but the results shown are different.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Business Analytics work center.
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Select the view Design Reports.
- Search for the report All Time Entries and open it.
- Enter the user you would like to check the Total Duration for under Time Entry Employee Responsible and select a Time Entry Calendar Month.
- Click Go to start the report.
- Add Key Figure Total Duration to the report view.
- You will realize that the value is different than shown in the related time report (to check the time report, please go to work center Time Reporting, view Time Reports).
Cause
The reason why the records do not to show up is due to the way the aggregation happens on unique records. This is the current behavior of the system and works as designed.
Resolution
To show the exact values and correct aggregation for all time entries, please include the characteristic Time Entry Created On (you will find it in the tab Available Fields) in the report view and refresh the report afterwards.
Now the key figure Total Duration shows the same value as in the original time report.
Keywords
Time Report, All Time Entries, key figure Total Duration, incorrect value, Time Entry, different value, CODTIME_ENTRY_Q0001 , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-SRP-TR , Time Report , How To