SAP Knowledge Base Article - Public

2709898 - When Converting a Lead to an Opportunity, not all Existing Notes are Copied into the New Opportunity

Symptom

When Converting a Lead to an Opportunity, not all notes are maintained in the New Opportunity: If the Lead initially had Notes maintained, they are not copied over.

If in the QueickCreate window of the Opportunity following up the Lead, you add Notes in the Note text box, they are no maintained in the Notes of the Opportunity, only the notes coming from the Lead view are.

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go to the sales workcenter.
  2. Go to the Leads view.
  3. New.
  4. Fill in the necessary fields including a Note in the text box of the QuickCreate.
  5. Click Save and Open.
  6. Add other Notes.
  7. Click Actions > Convert to Opportunity.
  8. In the followup Opportunity QuickCreate window, add another Note.
  9. Click Save and Open

Results: You are faced with two behaviors : only the notes maintained in lead QC shows and only the last notes and note from Quick Create show, the initial Note from the Lead is missing

Cause

When Notes Copy from Lead is copying all the Notes to the converted Opportunity takes place, the date/time of the Notes is the creation time of the Notes in opportunity which is correct, as the system is designed not to record the note history of leads into opportunity note text.

When it comes to the pattern of entering a new Note in the Opportunity (QuickCreate window) to be converted, it overwrites the one of the copied note from lead note history, hence the existing Lead notes are not copied over.

Resolution

This is the expected system behaviour.

Keywords

Notes Copy, Lead Notes, followup Opportunity Notes. , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions