Symptom
You created a Workflow Rule with Rule Type "Notification", but the Notification cannot be triggered as expected.
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Go to Administrator work center .
- Go to the Workflow Rules work center view.
- Search for Workflow Rule XYZ (XYZ represents the workflow rule name) and open it.
- Workflow Rule XYZ created with Type "Notification";Business Object "Ticket";and Timing "On Every Save".
- The condition maintain in the workflow XYZ is :Customer Update Equal to "Yes" AND Last Customer Interaction Not equal to 'Last Customer Interaction".
- Go to Service work center.
- Go to Ticket work center view and Open Ticket LMN(LMN represents the ticket number).
- Go to the Changes facet of Ticket LMN, where you can see the change made on the attribure "Customer Update" and "Response by Customer On", however, workflow rule XYZ was not triggered along with this change.
Cause
You created Workflow Rule XYZ with Timing "On Every Save", and Cancellation of Task option selected as "Conditions Not Met".
Under this setting, the notification will be generatedas soon as the conditions are met. But any other save after that, if the conditions don't meet then the notification task will get cancelled.
Resolution
To resolve this issue, you need to choose the option "Never" for Cancellation of Task in the workflow rule, and activate it again.
Keywords
Workflow;Notification not working;Cancellation of Task; , KBA , ticket , customer update , LOD-CRM-WKF , Workflow , How To