SAP Knowledge Base Article - Public

2710789 - Warning Message: 'Rule 01 - Service Units of Employee for View ABC in Business Role DEF determined no restrictions'

Symptom

You want to assign Business Role DEF (DEF represents the Business Role ID) to Business User XYZ (XYZ represents the Business User ID).

Business Role DEF has work center and view restrictions assigned which are not yet assigned to Business User XYZ.

When assigning the Business Role DEF to Business User XYZ, warning message shows: 'Rule 01 - Service Units of Employee for View ABC in Business Role DEF determined no restrictions.' (ABC represents the View name). Also, access restrictions are not updated for the user.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administration work center.
  2. Go to the General view.
  3. Click the Business Users link.
  4. Select Business User XYZ.
  5. Click Edit and select Access Rights.
  6. Try to assign Business Role DEF to the user.

Result: you receive warning message 'Rule 01 - Service Units of Employee for View ABC in Business Role DEF determined no restrictions.' and restrictions are not updated for the user.

Cause

Business User XYZ has no Service Units assigned.

Rule 01 has access based on the employee’s Service Unit and the subordinate Service Units. Because user does not have Service Unit assigned, restriction cannot be applied as restriction rule cannot determine any entity to make authorization for.

Resolution

Please check that the user has Service Units assigned. If not, change their assignment or adapt the Business Role accordingly.

Keywords

Business Role, Business User, Rule 01, Service Unit, Restrictions, View , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins 1808