SAP Knowledge Base Article - Public

2711764 - Data cannot be loaded at the second time of opening story based on Live HANA connection with SAML SSO in SAP Analytics Cloud (SAC)

Symptom

  • Data cannot be loaded at the second time of opening story based on Live HANA connection with SAML SSO in SAP Analytics Cloud (SAC)

Environment

  • SAP Analytics Cloud 2018.18.4
  • SAP HANA

Reproducing the Issue

  1. Clear chrome cache and restart Chrome
  2. Login to SAC tenant with custom SAML IDP configured. 
  3. Open one story based on Live HANA connection
    => The story displays correctly.
  4. Close chrome, open chrome again, login and open the same story
    => Data cannot be loaded into any widget(table, chart).
    => Go to designer of one widget, and found that the data source becomes unavailable.
    => Found 403 error for SSO request in Chrome development tools, but if openning the SSO request in a new tab, it will get correct response.
  5. Clear chrome cache and then restart chrome, login SAC, open the same story.
    => The story displays correctly.

Cause

The .xsaccess file in HANA is not in effect.

Resolution

Delete the .xsaccess file and recreate it again in HANA Web.

Workaround: using Chrome Incognito Window to access your SAC tenant.

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, Live HANA, IdP, custom, SSO, SAML, load data, display, show, shown, first, second, again, clear, cache , KBA , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , Problem

Product

SAP Analytics Cloud 1.0