SAP Knowledge Base Article - Public

2711879 - Error "Please enter a postal code" when Converting a Lead to Account

Symptom

You are trying to convert a lead to an account, but the error "Please enter a postal code" appears.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Open the lead ABC (ABC represents the lead ID).
  4. Press Actions -> Convert to Account.
  5. Press Save.
  6. The error appears.

Cause

 The country of the lead that you are trying to convert has street and postal code set as mandatory in the fine tune activity "Countries".

Resolution

This is the expected system behavior.

To remove mandatory postal code for the lead country, follow the below steps:

  1. Go to the Business Configuration work center.
  2. Go to the Overview view.
  3. Open the activity "Countries".
  4. Press "Edit Countries".
  5. Select the row of the affected country.
  6. Go to the Postal Attributes tab.
  7. Remove the flag for "Street Address Postal Code Required".
  8. Save changes.

Keywords

Postal Code, Convert, Lead, Account, Error , KBA , LOD-CRM-ACC , Account , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions