SAP Knowledge Base Article - Public

2712099 - Form I-9 Out of Compliance Shows US Form I-9 Section 2 Blank with Manager Signature - Onboarding

Symptom

  • Terminated or Suspended New Hires Employment due to out of compliance
  • I9 Section 2 Blank with Manager Signature and candidate's US I-9 form is out of compliance

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to SAP SuccessFactors HCM > Onboarding
  2. Take the hire's Onboarding workflow
  3.  Form I-9 Out of Compliance panel will show
  4. Terminate the New Hire's Employment is selected

    screenshot0027_ 10262018062202.png

  5. Assignee of Orientation Step (OS) confirmed that new hire will be terminated due to failure of bringing documents which prove's hire's eligibility to work in the United States.
  6. Assignee is required to sign US I-9 of new hire

    screenshot0028_ 10262018062207.png

    Cause

    The following notifications are disabled, changed, or deleted:

    • (3-Step I-9) Employee has not provided their proof of eligibility to work
    • (3-Step I-9) Term - Assignee - Employee has not provided their proof of eligibility to work
    • (3-Step I-9) Term - Payroll - Employee has not provided their proof of eligibility to work

    Note

    Name of the notification might be different if standard notification is edited

    Resolution

    For Live Customer(s)

    The standard behavior is when US I-9 is out of compliance and when it reaches Orientation Step (OS), assignee will encounter a panel with the options below.

    • Suspend the New Hire's Employment
    • Change the New Hire's Start Date (New Hire has not started to work)
    • Do Not Change the New Hire's Start Date
    • Terminate the New Hire's Employment

    If the assignee selected Terminate the New Hire's Employment, next panel will show a checkbox to confirm that new hire will be terminated due to failure of bringing documents which prove's hire's eligibility to work in the United States. The Onboarding process will not continue and activity will be deleted afterwards.

    Tried above resolution and it still won't work, try contacting support below.

    Contact SAP SuccessFactors Cloud Product Support

    Please reach out to SAP SuccessFactors Cloud Product Support in SAP One Support Launchpad via SAP Expert Chat or Support case. In addition, follow the template when creating an case and provide the needed information below.

    • Subject: KBA 2712099 - US Form I-9 Section 2 Blank with Manager Signature
    • Component: LOD-SF-OBD-I9

    Problem Description:

    1. BizX Company ID 
      • [Insert affected instance]
    1. Affected Hire/Candidate
      • [Insert affected hire/candidate's name]
      • [Insert screenshot of the issue]
    1. Username for Support Access (Read the agreement below)
      • [Insert Username]
    • May we have your approval for accessing your system environment to continue request? (Reply with your confirmation and username to access, refer to KBA listed below)
    • With your approval, accessing your system environment you agree for the actions we will take below.
      1. Review the data of affected users and compare it to those users who are working as expected.
      2. Capture screenshots/record screen clips of the issue.
      3. Analyze your system configuration
    • To know how to grant support access to SAP Cloud Product Support, please read the full article on 'How to Grant Support Access to SuccessFactors Support Staff' by clicking the reference KBA 2088892.

     

    For Implementation Partner(s) and Consultant(s)

    Avoid changing the configuration of mentioned notification in the cause section.

     

    For SAP SuccessFactors Cloud Product Support

    Please use the instruction manual on how to proceed, in the internal note

    Keywords

    SAP SuccessFactors, Onboarding, OBD, ONB, LOD-SF-OBD, PAN, EML, FRM, Blank I9, DHS, United States Department of Homeland Security, United States Citizenship and Immigration Services, USA, United States of America, Verification , KBA , onb-23140 , LOD-SF-OBD-FRM , Country Compliance Forms , LOD-SF-OBD-EML , Emails and Notifications , Problem

    Product

    SAP SuccessFactors Onboarding all versions