Symptom
Go to Termination screen and Scroll down to the Transfer Direct Reports section -> Choose "Individual transfer of direct reports" option. The New Manager Dropdown displays "No Data"
Environment
SuccessFactors Employee Central - Termination
Reproducing the Issue
- Go to Manage My Team -> Select the Direct Report Employee -> Click on Take Action -> Separation.
- Enter the Separation Reason, Resignation Date and Last Working Date etc.
- Scroll down to the Transfer Direct Reports section -> Choose "Individual transfer of direct reports" option
- Try to select any new user under the New Manager drop down. System displays No Data.
Cause
Fields of the type Worker (for example, supervisor in Job Information or HR/matrix manager in Job Relationship, and so on) now respect target groups defined in permissions. This means that, if configured, users can only add managers that are included in the target group defined in the permissions.
Resolution
Resolution 1
- In the Permission settings section, click the Permission button to specify the permission you want to assign to the role. The Permission Settings window opens.
Resolution 2
Uncheck the setting, Admin Center - Company System Setting - Enable target group based filtering for Worker fields.
Keywords
LOD-SF-EC-EMP, LOD-SF-EC-JOB, Termination, Direct Transfer, transfer of direct reports , KBA , LOD-SF-EC-TER , Termination Details , Problem