Symptom
You created a new Custom OData Service and noticed that now the No Authorization Checks flag is disabled.
Environment
-
SAP Cloud for Customer 1811 and higher.
Reproducing the Issue
-
Go to the Administrator work center, in the OData Service Explorer tab.
-
Click on the New button and create a new custom OData Service.
-
See the No Authorization Checks flag is disabled.
Cause
For custom OData Services, the option No Authorization Checks has been removed from the OData Service Explorer. Services that were previously marked for no authorization checks continue to work as before. However, you can edit the service to add authorizations accordingly.
Resolution
It is recommended that all OData services are assigned suitable authorizations.
This is the expected system behavior.
See Also
You can find the information also in the What's New section for the 1811 release.
Keywords
custom odata services, no authorization checks, odata service explorer , KBA , LOD-CRM-INT-API , OData API (C4C Only) , Problem