Symptom
You are trying to Cancel a Purchase Order item and the system shows the error message: Cancellation not allowed. Check open delivery documents
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to the Purchase Requests and Orders work center.
- Go to the Purchase Orders view.
- Select the relevant Purchase Order.
- Navigate to the Items tab and select the relevant Purchase Order Item.
- Select Cancel Item and the error will appear.
Cause
You have created Inbound Deliveries or Goods and Service Receipt document for the Purchase Order item. When Inbound Deliveries or Inbound Delivery Notifications are present, it is not possible to cancel either the Purchase Order or the Purchase Order item.
Resolution
In order to cancel the Purchase Order item, you have to cancel all follow up documents. Later you can cancel the purchase order item.
Follow the below steps from A to E to find any follow up documents in order to cancel them:
A. To search for all follow up documents linked to each line item of the Purchase Order follow the below steps:
- Go to the Purchase Requests and Orders work center.
- Go to the Purchase Orders view.
- Select the relevant Purchase Order.
- Navigate to the Items tab and select the relevant Purchase Order Item.
- Go to the item level document flow where you can see all documents linked.
B. Follow the below steps to find the Inbound deliveries if any:
- Go to the Inbound logistics work center.
- Go to the Inbound deliveries view.
- Show all inbound deliveries as per selection.
- Open the advanced filter.
- Enter the respective Purchase Order.
- Click on search to see if any inbound deliveries are present.
C. Follow the below steps to find the goods receipts if any:
- Go to the Goods and service receipts work center.
- Choose the Receipts and returns view.
- Show all Documents.
- Open the advanced filter.
- Enter the respective Purchase Order.
- Click on search to see if any goods receipts appear.
D. Follow the below steps to find the supplier invoices if any:
- Go to the Supplier invoicing work center.
- Go to the Invoices and Credit memos view.
- Open the advanced filter.
- Choose Order in the field Reference type.
- Enter the Purchase order ID in the Reference ID field.
- Click on search to see if any supplier invoices appear.
E. Follow the below steps to find the Inbound delivery notifications if any:
- Go to the Inbound Logistics work center.
- Select the Inbound Delivery Notifications view.
- Open the advanced search and enter the Purchase Order ID.
- Search for the relevant notification.
- Click on search to see if any inbound delivery notifications appear.
See Also
1347361 - How to Reverse / Cancel Inbound Delivery
2704119 - Error: Delivery processing for this Purchase Order is still active
Keywords
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