Symptom
You created a custom odata service using the business object Opportunity root node, but you could not find the field AccountName to add to the service.
Environment
-
SAP Cloud for Customer.
Reproducing the Issue
-
Go to the Administrator work center, in OData Service Explorer view.
-
Select the filter Custom OData Service.
-
Click on New and create the service.
-
Add the Business Object Opportunity and select the Root node.
-
You do not find the AccountName field.
Cause
The AccountName field is under DisplayNameSuitableForLogonLanguage under the label of FormattedName.
Resolution
-
You can find the AccountName field by navigating to the below path:
- Expand the Opportunity root node
- Find the ProspectParty node and expand it.
- Expand AddressSnapshot.
- Expand DisplayNameSuitableForLogonLanguage.
- See the field FormattedName.
Keywords
accountname, opportunity collection, custom odata service , KBA , LOD-CRM-OPP , Opportunity Management , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions