Symptom
When adding an item to a Ticket, the following error message is displayed:
'Quantity X,X ea has too many decimals; only 0 decimal(s) permitted'
Environment
SAP Clouod for Customer
Reproducing the Issue
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Go to the Service work center.
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Select the Tickets view.
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Select Ticket ABC (ABC represents the Ticket ID).
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Select the Items facet.
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Select the Add button.
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Add Product DEF (DEF represents the Product ID).
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Maintain a quantity of X,X ea.
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Select the Save button.
The following error message is displayed:
'Quantity 1,2 ea has too many decimals; only 0 decimal(s) permitted'
Cause
This is the expected system behaviour, if you did not allow decimals for the Unit of Measure.
Resolution
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Go to the Business Configuration work center.
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Select the Overview view.
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Find and open the Activity Quantities and Units of Measure.
- Select the Create and Maintain Trading Units hyperlink.
- Maintain the number of decimals you want to allow for each Unit of Measurement in the Display Decimals column.
- Select the Save button.
Keywords
Ticket Item Error Decimal Display Unit of Measure , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public