SAP Knowledge Base Article - Public

2714410 - Manage Competencies: Count shows zero '0' in Library list even if Competencies exists when library is opened

Symptom

Competency library shows zero even though competencies are present inside the library.

Environment

SuccessFactors Employee Profile

Job Description Manager

Reproducing the Issue

Admin Center > Company Settings > Manage Competencies.

As you see the part highlighted in red shows competency count is zero '0'.

(Screenshots taken from demo environment)

manage competency 1.png

When you open one of the Competency Library, you'll see that there are competencies inside. In this case, the translations defined are only for English_US locale.

(Screenshots taken from demo environment)

manage competency 2.png

Cause

Environment/instance default locale not matching with the defined translations for the competencies inside the library

Resolution

Your competencies needs to have a translation according to the defined default locale.

1. You need to check the back end settings. If you do not know your default locale, you can contact support to check it on your behalf. It is located in Provisioning > Company Settings > Default Language. In our scenario, the default locale is English_UK

manage competency 4.png

2. Once you are able to know your instance default locale, you can start to check the defined translations in Manage Compentencies. In this scenario, the only defined language is English US.

(Screenshots taken from demo environment)

manage competency 3.png

3. Define the translations by clicking the Add language for your default locale. You can also perform importing by following the steps in this KBA: 2230812 - Manage Competencies – Importing new Competencies

4. Go back to Competency Library list and check if it starts to count.

See Also

2230812 - Manage Competencies – Importing new Competencies

Keywords

Manage Competencies, JDM , KBA , LOD-SF-TIH-JDM , Job Description Manager , Problem

Product

SAP SuccessFactors HCM Core all versions