Symptom
- An application error occurs when approving a benefit claim workflow and it happens for everyone (approvers).
- Application error when loading Benefit overview screen in Employee Profile
Environment
- SAP SuccessFactors Employee Central
- Global Benefits
Reproducing the Issue
Scenario 1
Approve Benefit Claim workflow and application error is triggered
Scenario 2
- Access any Employee Profile
- Navigate to Benefit overview
- Application error with fingerprint=f82049521892a018c8d8924e8b625fd3cd8093c4,
Cause
- The Currency field in Benefits is blank.
- The Currency field is Inactive
Resolution
Scenario 1
- Select a value in the field of the benefit in Benefits Admin Overview
- Select Benefit from the first drop down
- Select the particular benefit from second drop down
- Take Action > Make Correction
- Select a value in Currency field
- Save the change.
The issue may continue for existing workflows, hence reject/withdraw existing workflows and trigger new workflows.
Scenario 2
Currency field is associated with Benefit
- Navigate to Manage Data > Currency
- Search for Currency that is associated with Benefit. Make sure to select Include inactive = Yes
- Change the status from Inactive to Active
Keywords
8b51d9725a9a55a44e57902d796689712f6f6358, NullPointerException, Currency, getCurrency, Claim, Workflow, Trigger, fingerprint=60a48130d6eea72d65a1e23c8575e17e95e97745, 60a48130d6eea72d65a1e23c8575e17e95e97745,f82049521892a018c8d8924e8b625fd3cd8093c4 , KBA , LOD-SF-EC-GBF , Global Benefits , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions