Symptom
When an external candidate logs in to their account to view their jobs applied, the location information is either blank, displaying the wrong Country, is incomplete or has the incorrect language translation for the job Country.
Environment
SAP SuccessFactors Recruiting Management (RCM)
Reproducing the Issue
- Login to your external candidate account.
- Go to the 'Jobs Applied' section.
- Notice how the job you have applied for is correct (Correct title), but the location information is either blank, incomplete, contains the wrong Country information, or the translation of the Country location is incorrect.
Cause
The location fields that are picked up and displayed in the portlet if configured and populated in the requisition are City, State and Country.
The translation of the country information comes from the logged in language of the external candidate, so whatever language the external candidate is logged in with will dictate the translation of the Country.
Resolution
Any missing or incomplete location in the jobs applied portlet must be traced back to the configuration of these fields in the corresponding requisition template and whether or not these were populated correctly in the requisition.
To ensure the translation is correct, please make sure that the external candidate is logged into the external carear site with the correct language.
Keywords
KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem