SAP Knowledge Base Article - Public

2715249 - Workflow Rule With Timing On Create Only is not Triggered When you Convert a Lead to an Account

Symptom

A workflow rule which was created with timing set to "On Create Only" is not getting triggered when you convert a lead to an account.

Environment

SAP Cloud for Customer

Reproducing the Issue

You have already created a workflow rule with timing "On Create Only" on Business Object Leads.

  1. Open a lead with a nonexisting account.
  2. Click Actions button.
  3. Click Convert to Account.
  4. Create an account based on the information maintained in the lead.

The workflow rule is not getting triggered.

Cause

While creating a Lead, a business partner of type account, a business partner of type contact and the relationship between both objects are already created in the backend (with a flag: only relevant for lead).

Resolution

The workflow rule will work fine by changing the timing of the workflow rule to "On Every Save". As the account is already created in the backend, the activation of the account on the UI by performing the Convert to Account action is considered as subsequent save by the system in the backend.

Keywords

Workflow Rule, On Create Only, Convert, Account, Lead , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions