SAP Knowledge Base Article - Public

2716630 - Conditions Limit For Queries In Advanced Search

Symptom

In Advanced Search of a given OWL (Object Work List) you want to do a big query adding over 1000 conditions, but when reaching the 1000th when you click on the "+" button it doesn't create new condition fields anymore.

Environment

SAP Hybris Cloud For Customer

Reproducing the Issue

Scenario 1:

  1. Go to any Work Center (e.g. Customer, Service, etc.).
  2. Click on the desired Work Center view (e.g. Accounts, Tickets, etc.).
  3. Click on the Advanced Search icon.
  4. Click on the More Options button of the field you want to query.
  5. By clicking on the "+" button add 1000 conditions.
  6. When you click to add the 1000th condition it won't create any further.

Scenario 2:

  1. Go to any Work Center (e.g. Customer, Service, etc.).
  2. Click on the desired Work Center view (e.g. Accounts, Tickets, etc.).
  3. Click on the Advanced Search icon.
  4. Using Google Chrome browser paste over 1000 values in any field which allow you to add conditions (This will automatically create 1000 conditions for each entry pasted).
  5. Click in the More Options of the desired field and you'll already have the conditions created.
  6. When you click to add the 501th condition it won't create any further.

Cause

The maximum number of conditions allowed in the Advanced Search - More Options of fields is 1000.

Resolution

This is the standard behavior of the system.

If you would like to see this behaviour changed in the system, you have two options below.

  1. You would like your company or an SAP Partner to implement the feature/functionality into your environment, e.g. by using the SAP Cloud Application Studio for custom coding
  2. You would like to wait for SAP to potentially add this feature / functionality into the Standard Product.
    This program is related to Products and Solutions. Ideas are reviewed by SAP Product Management. Votes help to prioritize ideas along with other important selection criteria such as:
  • DESIRABILITY: How many customers voted for this? How many customers will benefit from it?
  • VIABILITY: Is this Improvement Request globally relevant? Is this in alignment with SAP’s strategy for the product?
  • FEASIBILITY: Is the development effort realistic?  Is this request achievable within the product’s architecture?

    All ideas are welcome and valuable. However please note that the volume of ideas will usually be much higher than the scope of what we can accomplish on our product development roadmap. 

In case you choose option 1:

Reach out to the responsible decision maker within your company.

Your company may reach out to an SAP partner of your choice. You may like to consult the Partnerfinder.

In case you choose option 2:

In order for you to directly get in contact with the decision makers in SAP Product Management, please submit your enhancement request via the SAP Continuous Influence sites: SAP Cloud for Customer Sales or Service.

Keywords

Conditions; Advanced Search; More Options; Query; , KBA , AP-RC-MOB-UIF , Responsive UI , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions