Symptom
In the Visits tab within the Account TI, an error message is triggered when saving a value in the Visit Frequency field.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Customers work center.
- Go to the Accounts view.
- Open any Account ID.
- Go to the Visits tab.
- Select the Edit button.
- Enter an invalid entry in the Visit Frequency field (such as 200).
- Select the Save button.
- Error message triggered 'Enter the value in units of Year(s); Month(s); Day(s); Hour(s); Minute(s); Second(s); with number and time unit, for example, "4 Day(s) 9 Hour(s) 10 Minute(s)''. All time units may be abbreviated to the first unique letters; empty characters are not necessary.'
- Now enter 20 Minute(s) and select the Save button.
- The error message 'Weeks, Hours, Minutes and Seconds are not supported' is triggered.
This is misleading since the previous error message prompts the user to enter this time unit.
Cause
The first error message 'Enter the value in units of Year(s); Month(s); Day(s); Hour(s); Minute(s); Second(s); with number and time unit, for example, "4 Day(s) 9 Hour(s) 10 Minute(s)''. All time units may be abbreviated to the first unique letters; empty characters are not necessary.' is an error message directly triggered by the frontend UI for every duration field raised to ensure the content is entered in the right format.
The second error message 'Weeks, Hours, Minutes and Seconds are not supported' is a backend message specific to this field, since those units make no sense in the context of a recommended visiting frequency.
Resolution
Due to this constellation it would require substantial effort for little gain to adjust the frontend error message depending on the context, something development confirm is unrealistic to happen in the near future.
Keywords
KBA , 'weeks, hours, minutes and seconds are n , visit frequency , visits , accounts , LOD-CRM-ACC , Account , Problem