Symptom
The user is receiving multiple e-mail notifications when it is maintained as more than one business role.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Maintain the same employee in two different business roles.
- Create a workflow rule to send e-mail notifications.
- Maintain the business roles of the step 1 as recipient of the e-mail notification.
- Trigger the workflow.
- The user should receive two e-mail notifications.
Cause
In this scenario, because of different roles, the recipients are treated differently and hence two emails are sent out.
Resolution
This is the expected system behavior.
In order to avoid the user receive multiple e-mail notifications, you should maintain the user in only one business role or associate the role once on the workflow rule design.
Keywords
E-mail notification, Workflow, multiple e-mails, e-mail, notification, multiple, Cloud for Customer, C4C , KBA , LOD-CRM-WKF , Workflow , Problem
Product
SAP Cloud for Customer add-ins 1811
SAP Knowledge Base Article - Public