SAP Knowledge Base Article - Public

2718093 - Postal Code Validations not Working from 1811 Onwards

Symptom

When entering all 0's into the Postal Code address information field, no validation occurs upon continuing to the next section

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

Employee Central - Personal Information

Reproducing the Issue

  1. Add New Employee
  2. Populate the Postal Code field with 0000
  3. Continue to the next section
  4. No validation error

PostalCode1.png

PostalCode2.png

Cause

Since 1811, the Enable Address Validations in Company System & Logo Settings checks this field for all 0's. This check has not been enabled in the customer's instance.

Resolution

Enable this check by doing the following: Admin Center -> Company Logo & System Settings -> Check 'Enable Address Valdiations'

EnableAddressValidations.png

Try entering all 0's again and the system should show the validations error

Validation.png

Keywords

Postal Code Validations Error Enable Address Personal Information , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central all versions