Symptom
You have created a workflow rule using the Created By or Change By field and matched it against the Technical User.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Workflow Rules view.
- Click on New.
- Enter Basic Data.
- Define Condition using Created By or Changed By field and Technical User as reference.
- Define Actions.
- Activate workflow rule.
- Workflow rule is not being triggered for the Technical User reference.
Cause
- The field Created By is bind to path \CREATION_IDENTITY\PERSON\CURRENT_COMMON. However, a technical user doesn't have a real BP because it is just a Technical User. Therefore, the condition fails to execute.
- Example Scenario: You have an opportunity Created By "Technical User", and you have Workflow Rule Condition like "Created By xxx XXXX". The Workflow will never trigger for this Opportunity because Created By is matched against "Technical User", which is the created by user of the Opportunity.
Resolution
This is the standard behavior of the system. The system doesn't allow using Created By or Changed By field and matched it against the Technical User. For evaluation of condition based on field Created By or Changed by, a business partner instance should be present. However, Technical user doesn't have a BP so the system doesn't allow this and fails.
If you consider this to be changed within the system, we would like to kindly ask you to post this idea in the forum (please go to 'Help' at the top of the screen and choose ''Make SAP Cloud for Customer Better'' - https://influence.sap.com/SAPCloudforCustomer).
Keywords
Workflow Rule, Technical User, Business Partner , KBA , workflow rule , technical user , business partner , LOD-CRM-WKF , Workflow , How To