Symptom
A Workflow Rule was created using the Created By or Changed By field and the Technical User as a value.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Workflow Rules view.
- Click on New.
- Enter Basic Data.
- Define Condition using Created By or Changed By field and Technical User as reference.
- Define Actions.
- Activate Workflow Rule.
- Workflow Rule is not being triggered for the Technical User reference.
Cause
The field Created By is bind to path \CREATION_IDENTITY\PERSON\CURRENT_COMMON. However, a technical user doesn't have a real BP because it is just a Technical User. Therefore, the condition fails to execute.
Example Scenario: There is an Opportunity Created By "Technical User", and a Workflow Rule Condition like "Created By equal to Technical User". The Workflow will never trigger for this Opportunity because Created By is matched against "Technical User", which is the Creator of the Opportunity.
Resolution
This is the standard behavior of the system.
The system doesn't allow using Created By or Changed By field and matched it against the Technical User. For evaluation of condition based on field Created By or Changed by, a Business Partner instance should be present. However, Technical user doesn't have a BP so the system doesn't allow this and fails.
If this should be changed within the system, then please post this idea in the SAP Influence Site.
See Also
Keywords
WKF, employee, person, people, sap_system, not equal to, before object change, matches pattern, does not match pattern, operator, , KBA , LOD-CRM-WKF , Workflow , Problem
SAP Knowledge Base Article - Public