Symptom
After configuring the talent pool based on the implementation/admin guide, the Talent Pool link is now visisble in the Candidate tab. When creating a new talent pool, the button is not responding.
Getting "Error when saving Talent Pool <name>. Please try again"
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
1. Login to instance
2. Go to Recruiting > Candidate
3. Select the Talent Pool option
4. Click Create Talent Pool button.
Cause
This issue will usually happen if there were any recent changes in MDF object data.
Resolution
If there is recent update in MDF object data, it is advised to do an MDF refresh. To perform an Metadata Refresh, go to Admin Center > OData API Metadata Refresh And Export > Refresh Cache.
See Also
2643661 - Candidate Talent Pool - Recruiting Management
Keywords
Candidate Talent Pool not responding, Candidate talent pool Create button not working , KBA , LOD-SF-RCM-CRM , Candidate Relationship Management , Problem