Symptom
When external users register through Sites and they add an email address that is already linked to another user, a warning message appears:
However, in System Admin>Configuration>System Configuration>LMS_ADMIN the value 'selfRegistrationUniqueEmailAddressRequired' is set to 'True'
This setting should prevent the user from registering and provide a validation error as follows:
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- In System Admin>Configuration>System Configuration>LMS_ADMIN, set 'selfRegistrationUniqueEmailAddressRequired=true'
- Try to register an external user via Sites using an email address which is already associated with a Learning User
Cause
- An 'Approval process' in the External Sites 'Registration Validation' setting
- The association of an approval process with the external site does not currently support the creation of an integrated BizX user.
- This means that if approval process is used, the registered user is only created in LMS and not in BizX and the site will not recognize the email of the previously existing email address.
Resolution
- In order for the 'selfRegistrationUniqueEmailAddressRequired' configuration to work as expected, the Site cannot use the approval process.
- You can disable the approval process in the site settings under the 'Registration Validation' settings drop-down. The site registration will then require a unique email address as requested.
See Also
Keywords
External Site, External User, Register, Unique email, selfRegistrationUniqueEmailAddressRequired, user already exists with an email address, user already exists, , KBA , LOD-SF-LMS-EXT , Sites and External Users , LOD-SF-LMS , Learning Management System , How To