Symptom
An exception has been created to enable editing of an enrollment. But the system throws an application error when saving the enrollment after edit. This issue may also occur when claiming a benefit as well.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central: Global Benefits
Reproducing the Issue
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Create an exception for edit of enrollment.
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Make sure that the enrollment period for the benefit is in past.
- Search a user who has already enrolled for this benefit.
- The enrolled benefit should have an Edit option. Edit it and change some data.
- Save it to get the application error.
Cause
Currently, edit of enrollment for benefit of type Reimbursement is not supported if a claim already exists for the subject user for the benefit in question. The behavior is same even when trying to edit an existing enrollment for a Reimbursement through exceptions.
Resolution
Don't create an exception for Edit of Enrollment of a Reimbursement type benefit when a claim exists for the user. As a work-around, the existing enrollment should be deleted and then an exception can be created for Enrollment for the user and benefit.
If the issue is occuring when claiming a benefit, it may be because the user is claiming the benefit outside the claim period. Example - The schedule period maintained in Benefit is April 2019 to March 2020 but employee is claiming the benefit on 31st March 2019. To resolve this issue, kindly add a period of March (in the above example) under schedule periods of that particular benefit.
Keywords
Enrolment, Message key is null, Claim, Reimbursement, schedule, period, workflow, BENEFITS_INVALID_PREVIOUS_ENROLLMENT_ID , KBA , LOD-SF-EC-GBF , Global Benefits , Problem