SAP Knowledge Base Article - Public

2721909 - Workflow Sends Email To a Different Recipient

Symptom

You noticed that your workflow reached a recipient that was not configured in the rule.

Environment

SAP Cloud for Customer

Reproducing the Issue

Lets suppose you have a workflow configured to send emails to an Employee Responsible based on Leads creation. You also have selected  the Rule Type "E-mail" and the checkbox "Always Send E-mail" is marked.

in order to trigger the workflow you have followed the below steps:

  1. Go to the Sales work center.
  2. Select the Leads view.
  3. Click on New.
  4. Fill the mandatory fields and enter an Employee Responsible.
  5. Save and Open.
  6. Result: the workflow is triggered and reached the main recipient, Employee Responsible, for example, and also a different one not configured in your rule.

Cause

You have the same Business Partner name, Contact and Employee, for example, with two different e-mail addresses. When a workflow is triggered, it takes into the consideration the name and not what is maintained on the recipient rule. Because of that, Cloud for Customer will reach both Business Partners.

This also applies for other objects such as Opportunities, Sales Quote, Sales Order, Activities and Tickets.

Resolution

This is the current system behavior.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:

Keywords

e-mail, emails, workflow, recipient , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions