Symptom
You noticed that your workflow reached a recipient that was not configured in the rule.
Environment
SAP Cloud for Customer
Reproducing the Issue
Lets suppose you have a workflow configured to send emails to an Employee Responsible based on Leads creation. You also have selected the Rule Type "E-mail" and the checkbox "Always Send E-mail" is marked.
in order to trigger the workflow you have followed the below steps:
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Go to the Sales work center.
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Select the Leads view.
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Click on New.
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Fill the mandatory fields and enter an Employee Responsible.
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Save and Open.
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Result: the workflow is triggered and reached the main recipient, Employee Responsible, for example, and also a different one not configured in your rule.
Cause
You have the same Business Partner name, Contact and Employee, for example, with two different e-mail addresses. When a workflow is triggered, it takes into the consideration the name and not what is maintained on the recipient rule. Because of that, Cloud for Customer will reach both Business Partners.
This also applies for other objects such as Opportunities, Sales Quote, Sales Order, Activities and Tickets.
Resolution
This is the current system behavior, however, you can place a new request in our influence idea using the following channel: https://influence.sap.com/SAPCloudforCustomer.
There is also another possibility to contact our Service center team, please see their contact details below:
You can find more details about the services offered by the Cloud Service Center on https://www.sap.com/services/application-development.html.
You can contact the Cloud Service Center as follows:
a) If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
b) If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
Keywords
Emails ; Workflow ; Recipient , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-LM , Lead Management , How To