Symptom
You have set the Default Font on Company Settings but they are not working as expected.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to Company Settings.
- Go to UI Controls.
- Set Default Font and Default Font Size.
- Go to Tickets.
- Open any ticket.
- Copy and paste a content from word or any website and paste it in the Formatted Text field.
- Choose the content and from the drop down select "Default Font" and "Default Font Size".
- You will see that it is not applied.
Cause
-
The default font, size that the user maintains in the company settings is what we default to when the user opens the editor the first time.
- So if the user has maintained Arial, 8pt in the company settings that's what we automatically select in the Font style, size drop downs in the email editor the first time it's opened.
-
However the "Font - default" and "Size - default" that you see in the email editor drop downs correspond to "DejaVu Serif" and "12px " as defined by the editor.
- Therefore when the user selects some text and changes it to "Font - default" and "Size - default" they are actually changing it to DejaVu Serif, 12px and not Arial 8px.
Resolution
This is the system expected behavior.
After updating the Font on Company Settings, it is advisable to clear the browser cache and log on again to the system.
Keywords
copy and paste, rich text, default font, default font size , KBA , AP-RC-MOB-UIF , Responsive UI , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions