SAP Knowledge Base Article - Public

2722644 - The Product List Is Not Available To Be Added on a Sales Document

Symptom

The product list is not available to be added on a Sales Document.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Sales Orders work view.
  3. Open the Sales Order 123 (The Sales Order ID is defined as 123).
  4. Go to the Product tab.
  5. Click on More button.
  6. Click on Add from Product List.
  7. The product list defined is not available to be added. 

Cause

For this case, there are some configurations that could be the cause:

  1. The Product List is not configured to be available for all accounts. For this reason, the Product List will only be displayed whether the Account maintained on the Product List is the same associated to the Sales Document.
  2. The Sales Area maintained on the Product list is not the same on the Sales Document. In case the Product List has a Sales Organization maintained, it should be  kept on the Sales Document as well.
  3. The Sales Territory on the Product List does not match with the Sales Territory configured on the Sales Document.
  4. The Sales Data maintained on the Product level is not the same of the Sales Document. In this case, even if the Sales Data of the Product List is the same of the Sales Document, in case on the Product level the Sales Data is different, the Product List will not be available to be added on the Sales Document.

Resolution

In case the user wants to make the Product List available for all Accounts, the following configuration should be done:

  1. Go to the Products work center.
  2. Go to the Product List work view.
  3. Open the Product List ABC (ABC represents the name of the Product List).
  4. Maintain the checkbox "Valid for All Accounts" marked.

In case the user wants to make the Product List available for any Sales Area or Territories, the user may not specify the Sales Area or Sales Territories on Sales tab under the Product List. Therefore, if no Sales Area or Sales Territories are defined, the product list is valid for all Sales  Area or Sales Territories.

In case the Sales data of the product is defined and it is different of the Sales document, the user could maintain the same Sales data for both documents or remove the Sales data from product item.

See Also

You can find more information on following SAP documents:

SAP Admin Guide - Product Administration.

  • KBA 2195614 - Product List is not available while adding Products in Sales Order
  • KBA 2674351 - Product Lists is Empty While Creating a Sales Order
  • KBA 2613418 - Product List Not Available For Selection In Sales Quote

Keywords

Sales Orders, Sales Quotes, Product List, Product, Sales Data. , KBA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-CRM-PRO , Products , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions