Symptom
You try to set as Mandatory a field (standard, KUT and PDI) bound to a row, however, this property is missing.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Open Account XYZ (XYZ represents the ID of the Account).
- Click on Adapt --> Edit Master Layout.
- Go to the Address facet.
- Select an address and, under Details section, try to set a field as mandatory.
- You will notice that the mandatory option is missing for all the fields under this section.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Cause
If a field is bound to a row of a table, the mandatory will not work on all the table items.
When you have data that is not present all the time (know as Lazy Loading), the Mandatory Check will not be allowed (in the case of tables, for example, when you enter data).
Thus, the marking as mandatory option was disable for this scenario.
Resolution
This is the standard behavior of the system.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
See Also
This also occurrs for other fields bounded to table, e.g. fields under Products inside a Ticket:
Keywords
Mandatory; Property; Missing; Not Available; Table; Field; , KBA , account , mandatory , address , accounts address field mandatory , AP-RC-UIF-RT , UI Framework Runtime , How To