Symptom
- When candidates with an active Employee Referrer information are forwarded in a requisition by a recruiting user, the adhoc report shows duplicate records for these applications with different Referrer information. One record shows the employer who referred the candidate, the other shows the recruiting user who forwarded the candidate to the requisition.
- Two different ReferralID is created for the same candidate ID.
Environment
SuccessFactors Recruiting Management
Cause
This is an expected behaviour. In ad hoc report, we are actually not seeing duplicate records, as these two entries have different "Referral Type" information. The record with the employer who referred the candidate showing as the referrer will have a Referral Type of "Employee", while the record with the recruiting user showing as the referrer will have a Referral Type of "CandFw". Hence, no duplication of data are being reported in the ad hoc report.
Resolution
Assign a filter in the report wherein only a Referral Type of "Employee" will show in the report in order to pull the correct Referrer information. The Referral Type field is available under the Referrals linked on Application column.
Keywords
Adhoc Report, Employee Referral, Duplicate Records, Referrals linked on Application, Referral Type, ReferralID, duplicate , KBA , LOD-SF-RCM-REP , Reporting & Analytics, Data Imports & Exports , LOD-SF-RCM-APP , Applicants and Job Applications , Problem