Symptom
You have created a Workflow Rule with Timing On Create Only. However, the rule is not executed when you add the condition with the field Created On, Created By, Changed By or Changed On.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Workflow Rules view.
- Create a Workflow rule with the below details:
- Business Object: Account, Contact, or any sales document.
- Timing: On Create Only OR On Every Save (when the document gets created).
- Conditions: use one of the following - Created On / Changed On equal to DD.MM.YYYY (DD.MM.YYYY represents a date) OR Created By / Changed By Equal to ABC (ABC represents the Employee ID).
- Rule Type: any type.
- Select Action: DEF (DEF represents the Action ID).
Please note that the following steps are only an example to reproduce the described outcome:
-
Go to the Customers work center.
- Go to the Accounts view.
- Click the New button.
- Fill in all mandatory fields.
- Click the Save button.
Result: The Workflow Rule is not triggered.
Cause
The fields Created By, Created On, Changed By, Changed On are part of System Administrative Data and are only written after the Object Creation or Update, in this case, the Account.
When the system is checking whether a workflow rule should be triggered for this object, the data inside fields Created On, Created By, Changed By or Changed On still does not exist. Hence, the workflow rule will not be triggered.
Resolution
This is the expected system behavior.
Keywords
workflow rule, created on, changed by, created by, changed on, lead, opportunity, sales quote, sales order, account, contact , KBA , workflow rule , assign me as owner , condition , created by , created on , changed by , changed on , LOD-CRM-ACC , Account , LOD-CRM-WKF , Workflow , How To