Symptom
While importing a Compensation template into an instance you may get the following error message.
**All images are from demo instances**
Environment
- SuccessFactors Compensation
Reproducing the Issue
- Access Compensation Home
- Select "Add Leading Practice Plan"
- Select "Upload a custom template"
- Select the your file and "Upload a custom template"
- Error then generates
Cause
The reason this message populates is due to the background element payComponentNonRecirring being disabled.
This needs to be enabled at the moment for Compensation for validation of the template xml.
To check this please navigate to Admin Center> Company Settings> Manage Business Configuration.
This occurs due to the template validating itself against the data-model during the import process.
Resolution
To correct this and have the template import correctly please have this enabled within your business configuration.
Should this behaviour change in future releases this KBA will be updated accordingly.
Keywords
component data model, error importing template, custom template, can not find payComponentNonRecurring, payComponentNonRecurring , KBA , LOD-SF-CMP , Compensation Management , Problem