SAP Knowledge Base Article - Public

2723614 - Error Message "End date XX.XX.XXXX must be after lead start date YY.YY.YYYY; enter new date" Does Not Prevent From Saving Lead

Symptom

The error message "End date XX.XX.XXXX must be after lead start date YY.YY.YYYY; enter new date" is displayed when the End Date is before Lead Start Date, but it does not prevent you from save or create the Lead (XX.XX.XXXX represents the End Date) and (YY.YY.YYYY represents the Start Date).

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Click on New.
  4. Fill in the mandatory fields.
  5. Set the End Date before the Start Date.
  6. Press Enter.
  7. The error message "End date XX.XX.XXXX must be after lead start date YY.YY.YYYY; enter new date" is displayed, but it does not prevent you from save the Lead, and you are expecting that this error message will not allow you to save the Lead.

Cause

The error message "End date XX.XX.XXXX must be after lead start date YY.YY.YYYY; enter new date" will be displayed to alert the user to not make this change, because it will cause inconsistencies in the document.

However, the system will not prevent the user from saving the Lead.

Resolution

This is the expected system behavior.

It is not advised to keep the Lead inconsistent, because in case the Lead is inconsistent, any follow-up actions like conversion will trigger an error message.

Keywords

Lead, End Date, Start Date , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions