Symptom
Using "Manage My Timesheet" application, a new record is created but clicking on Save button, it seems that record isn´t stored on database.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP S/4HANA Cloud Public Edition
Reproducing the Issue
-
Open 'Manage My Timesheet' application
- Create a new record and fill any additional field available on Details section (extensibility mode is activated).
- Click on Save button:
Please note that Additional fields could also be displayed on a popup: - Going back to Home page and opening again Manage My Timesheet application, you check that new record isn´t created.
Cause
It's necessary to click on Save button, available on footer toolbar to get the records stored in database.
Resolution
In order to have 2 different buttons to save and submit actions, it's necessary to have flag 'Release On Saving' unchecked on "Manage Your Solution" application:
Then next buttons will be available on the application:
When creating a new record, Save button available on Details section is just designed to store the additional fields to this record.
However, Save button available on footer toolbar will store the timesheet record on status 'In process (Saved)' on database.
See Also
Keywords
KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , How To