Symptom
In the Relationships tab of a Contact, when you are adding an Account, the error message 'You have already created a relationship with the same business partner. Adapt the relationship you just added or remove it.' is triggered.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Customers work center.
- Go to the Contacts view.
- Open the Contact ABC (ABC represents the Contact ID).
- Go to the Relationships tab.
- Select the Add button.
- Choose a Relationship type from the dropdown field.
- Now open the Business Partner OVS and selected Account DEF (DEF represents the Account ID).
- The error message 'You have already created a relationship with the same business partner. Adapt the relationship you just added or remove it.' is triggered.
Cause
You can only add any Account once and you have already maintained a Relationship for this Account.
Resolution
This is the expected system behaviour.
Keywords
KBA , LOD-CRM-CON , Contact , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions